Python3 安装 BuiltWith 模块

2017年3月26日21:33:50 3 993

BuiltWith是一个网站技术信息查询工具,开发团队来自于澳大利亚。利用该网站所提供的功能,你可以查询出某网站背后是由哪些技术来支持的,比如操作系统的类型、所采用的访问量统计服务、采用的发布平台、广告平台、语言框架、聚合功能、页面文档信息、网站编码及操作系统信息等等。可帮助更深一层次了解该网站的运营情况。

但是这么好的工具是 python2 开发的,python3 的语法和 python2 有一些区别,所以 BuiltWith 不能在 python3 下直接使用,我们修改部分代码就可以完美兼容 python3 了

我的 python3 安装在 /usr/local/python/ 目录下,所以 BuiltWith 安装在 /usr/local/python/lib/python3.5/site-packages/builtwith 下。我们把这个目录下的 __init__.py 文件替换成下面的代码即可。

声明一下:以下配置在 CentOS 6测试通过,其他系统请随机应变

如果你还没安装pip,root用户可以用下面命令安装

首先通过pip安装BuiltWith

然后覆盖__init__.py文件

在网页编码时需要通过 chardet.detect() 获取原网页的编码

需要安装 chardet 包,我们通过 pip 安装

下面我们测试一下BuiltWith

Python3 安装 BuiltWith 模块

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

目前评论:3   其中:访客  2   博主  1

    • avatar 601142395 1

      还是没法运行,Python新手麻烦帮忙看看,错误代码如下:
      import builtwith
      Traceback (most recent call last):
      File “”, line 1, in
      import builtwith
      File “”, line 961, in _find_and_load
      File “”, line 946, in _find_and_load_unlocked
      File “”, line 885, in _find_spec
      File “”, line 1157, in find_spec
      File “”, line 1131, in _get_spec
      File “”, line 1112, in _legacy_get_spec
      File “”, line 427, in spec_from_loader
      File “”, line 544, in spec_from_file_location
      zlib.error: Error -5 while decompressing data: incomplete or truncated stream

      非常感谢!!!

        • avatar 小小雷 Admin

          @601142395 环境问题确实很头疼,推荐你安装pyenv,可以在多个版本之间切换,很方便。还有python 2.7 是 py2 和 py3 的一个过渡,基本兼容py3的语法,学习的话用 py2.7 很不错

            • avatar 601142395 1

              @小小雷 非常感谢^O^今天回去就安pyenv试一下